76FoMoCo

SHO Member
Joined
Nov 22, 2018
Messages
1,174
Reaction score
1,240
Location
Nampa, ID
He only tried 5800 in 2020 before that he did do 6200 and when I was full interior as well lol. I think 5800 is leaving power on the table even if on a dyno it shows it falling off.
Two weeks ago at the track
 

Attachments

  • 20220605_093332.jpg
    20220605_093332.jpg
    276.5 KB · Views: 21

RickyRecon

Active Member
Supporting Member
Joined
Apr 23, 2022
Messages
106
Reaction score
109
Location
Northwest Indiana
Yeah for sure, let me know I’m curious. Either way, if he saw something in the log regarding my TC then I guess there’s gotta be some sort of issue there.
He just emailed me and said my logs look good. His exact words were, “maybe another point of octane to be perfect, but other than that nothing else to change.”

I did put the extra pint of trans fluid in this morning, and it’s shifting smoother across the board, but you said you already did that to yours. Even my 5th to 4th is smoother than yesterday. Im just gonna keep and eye and give it more time to adapt. I’m thinking it’s that, and the advance trac not liking the extra torque at first maybe.
 

cordell

Member
Joined
May 24, 2021
Messages
42
Reaction score
9
Location
Maine
He just emailed me and said my logs look good. His exact words were, “maybe another point of octane to be perfect, but other than that nothing else to change.”

I did put the extra pint of trans fluid in this morning, and it’s shifting smoother across the board, but you said you already did that to yours. Even my 5th to 4th is smoother than yesterday. Im just gonna keep and eye and give it more time to adapt. I’m thinking it’s that, and the advance trac not liking the extra torque at first maybe.
True that. Anyone ever dealt with crank relearn? And maybe I should do another KAM reset or is that pointless? I installed the correctly gapped plugs like 4-5 days after uploading the GH tune so maybe that has something to do with it? Hmmm
 

SeanDev

SHO Member
Joined
Jun 6, 2021
Messages
295
Reaction score
255
Location
46131
True that. Anyone ever dealt with crank relearn? And maybe I should do another KAM reset or is that pointless? I installed the correctly gapped plugs like 4-5 days after uploading the GH tune so maybe that has something to do with it? Hmmm
No need for a crank relearn. Unless you changed out the PCM. If you do a KAM reset, remember be patient, drive casual for awhile, drive crazy for awhile, and mix them up. Takes hundreds of miles for the car to relearn. Not caught up but you mentioned shift issues, I might have miss it, but are you running upgraded trans mounts?
 

cordell

Member
Joined
May 24, 2021
Messages
42
Reaction score
9
Location
Maine
No need for a crank relearn. Unless you changed out the PCM. If you do a KAM reset, remember be patient, drive casual for awhile, drive crazy for awhile, and mix them up. Takes hundreds of miles for the car to relearn. Not caught up but you mentioned shift issues, I might have miss it, but are you running upgraded trans mounts?
I am not. That’s something to look into. 1-2 shifts and syncs up perfect but2-3 and so on bumps/jolts into gear.b
 

SeanDev

SHO Member
Joined
Jun 6, 2021
Messages
295
Reaction score
255
Location
46131
I am not. That’s something to look into. 1-2 shifts and syncs up perfect but2-3 and so on bumps/jolts into gear.b
Trans mounts are a must. 99% of your shift problems are a side effect of stock torsion "trans" mount. Stock mounts hate more power. That's wheel hop your experiencing. Research here about AD mounts. Well worth the money, easy install. World of difference. Need his contact for Facebook just ask. Great guy, high quality product.
 

cordell

Member
Joined
May 24, 2021
Messages
42
Reaction score
9
Location
Maine
Trans mounts are a must. 99% of your shift problems are a side effect of stock torsion "trans" mount. Stock mounts hate more power. That's wheel hop your experiencing. Research here about AD mounts. Well worth the money, easy install. World of difference. Need his contact for Facebook just ask. Great guy, high quality product.
Appreciate it. Yeah, what is the best way to contact him?
 

SeanDev

SHO Member
Joined
Jun 6, 2021
Messages
295
Reaction score
255
Location
46131
Appreciate it. Yeah, what is the best way to contact him?
Just message him, the transaction can all take place through Facebook messenger. He is a legit business man, and is respected for his service especially here in this forum and others.

What year is your SHO? His comes with both front and rear. I have a 2018 so i had to buy front mount and have shop weld plates on frame to secure front one. Ford being lazy deleted front mount for last couple years.
 

SeanDev

SHO Member
Joined
Jun 6, 2021
Messages
295
Reaction score
255
Location
46131
He will send detailed instructions with his mounts, follow them, you'll have a little more vibration, to me it's worth it. I like feeling power rumble the steering wheel.
 

Ta2dResqr

SHO Member
Joined
Dec 10, 2020
Messages
600
Reaction score
525
Location
Central Ohio
Appreciate it. Yeah, what is the best way to contact him?
Just a heads up, in the past he has wanted payment Friends and Family. While I normally would pass on a purchase with that requirement, AD is a stand up guy. I have made 2 purchases Friends and Family with both shipped with tracking number same day and product in hand, great packaging, excellent product within a week.
 

sanman

SHO Member
Joined
Aug 5, 2015
Messages
103
Reaction score
54
Update - so I have the GH tune in, extra quart tranny fluid and correctly gapped plugs now. Been running it for a couple weeks, and probably have roughly 200-300 miles or so. Before I uploaded the tune, I did a kam reset and it’s definitely improved and adapted since then. BUT (and I’m starting to think it’s a mechanical part on my car and not the tune, since the tune is fine for everyone else…), it still does this funky hesitation/shuddering shift, which is more prominent with WOT and accelerating around turns. 1-2 is butter, 2-3 is where its the roughest and 3-4 and so on are also kinda choppy but to a lesser degree. As I stated before, me transmission is new from the dealer as of 20k miles ago. I sent in a log to Matt and he said the only thing he saw was that my torque converter was having trouble locking. I read up on torque converters and the symptoms and I guess it could be that. Anyways, my update is that GH is much better than LMS, but I still can’t drive the car WOT or “freely”, I always have to be cautious/mindful how much I’m accelerating and the timing for it to not shift so hard. It’s also not consistent - one time I can go 2-3 with 90% acceleration and it’s relatively fine, then next it shuddering into 3rd gear and it freaks me out. It’s drivable no doubt, but I wanna be able to get it to shift like butter whether I’m going around a tight bend and acceleration or doing a 2nd gear pull starting at 3000 rpm’s and pinning it. Any other info is greatly appreciated thanks boys.
What made you put extra qt of tranny fluid? I just tuned my car and shifting is a little funky ( to much time between shifts) and my turbo seems to spool a little louder. Is that why you added a qt.
 

sanman

SHO Member
Joined
Aug 5, 2015
Messages
103
Reaction score
54
What made you put extra qt of tranny fluid? I just tuned my car and shifting is a little funky ( to much time between shifts) and my turbo seems to spool a little louder. Is that why you added a qt.
What made you put extra qt of tranny fluid? I just tuned my car and shifting is a little funky ( to much time between shifts) and my turbo seems to spool a little louder. Is that why you added a qt.
Sorry just read the thread i know why now thanks
 

cordell

Member
Joined
May 24, 2021
Messages
42
Reaction score
9
Location
Maine
Sorry just read the thread i know why now thanks
Yeah. So, I just received a “softer shifting” tune. It did help overall, BUT still, from 2-3 it just feels like it’s almost going into fear too quick, which makes my slightly jolt in my seat. Bottom line is it doesn’t sync up and feel like butter like 1-2 does, when it should… 3-4, 4-5 and 5-6 aren’t nearly as noticeable as 2-3. We’ll see what happens, maybe it’ll adapt more to this modification but I doubt it…
 

sanman

SHO Member
Joined
Aug 5, 2015
Messages
103
Reaction score
54
Yeah. So, I just received a “softer shifting” tune. It did help overall, BUT still, from 2-3 it just feels like it’s almost going into fear too quick, which makes my slightly jolt in my seat. Bottom line is it doesn’t sync up and feel like butter like 1-2 does, when it should… 3-4, 4-5 and 5-6 aren’t nearly as noticeable as 2-3. We’ll see what happens, maybe it’ll adapt more to this modification but I doubt it…
My problem is @ wot and turbos spool loader then normal and the car feels like a boat and really no pickup shifting in not shifting quick enough im thinking maybe trans fluid, but its odd all of a sudden after tuning the car this started happening. Maybe a boost leak not sure... Car only has 30k so its still a baby...
 

RickyRecon

Active Member
Supporting Member
Joined
Apr 23, 2022
Messages
106
Reaction score
109
Location
Northwest Indiana
My problem is @ wot and turbos spool loader then normal and the car feels like a boat and really no pickup shifting in not shifting quick enough im thinking maybe trans fluid, but its odd all of a sudden after tuning the car this started happening. Maybe a boost leak not sure... Car only has 30k so its still a baby...
Yeah try going a pint heavy on the trans fluid. It made a noticeable difference for me. It didn’t completely take away the “issues”, but that will probably be fixed when I put the mount on
 

cordell

Member
Joined
May 24, 2021
Messages
42
Reaction score
9
Location
Maine
Yeah try going a pint heavy on the trans fluid. It made a noticeable difference for me. It didn’t completely take away the “issues”, but that will probably be fixed when I put the mount on
I think it’s technically a quart heavy. 2 pints = 1 quart. Same idea I guess, just double it.
 

RickyRecon

Active Member
Supporting Member
Joined
Apr 23, 2022
Messages
106
Reaction score
109
Location
Northwest Indiana
Just message him, the transaction can all take place through Facebook messenger. He is a legit business man, and is respected for his service especially here in this forum and others.

What year is your SHO? His comes with both front and rear. I have a 2018 so i had to buy front mount and have shop weld plates on frame to secure front one. Ford being lazy deleted front mount for last couple years.
Did you run it with just the rear before having the plates welded on for the front mount? I have a 2017 so I’m curious how much is improved with just the rear mount, or if the front it “necessary”
 

cordell

Member
Joined
May 24, 2021
Messages
42
Reaction score
9
Location
Maine
UPDATE: I called the Ford dealer, they said they 110% replace the torque converter whenever they replace a transmission (which was replaced 1.5 years ago). Matt from GH was talking about strategy codes and the valvebody with the new tranny as well, so I asked about that and the Ford dealer said they have to do that or else the new transmission just won’t work right. Now, the torque converter could have gone bad over the last 1.5 years, although I doubt it? Kinda just bummed. No idea what this could be. Matt sent me a softer shifting tune which helped minimally, but the problem still persists. I do have a warranty so I can bring it to Ford for free but in that case, I’d have to revert my car back to stock and then the problem may not be there anymore, in which they’d probably just tell me that everything is fine. Dealt with this issue with LMS for almost 2 years, decided to buy GH and it’s still here. I still doubt it’s the GH tune since all of you have like no issues, but damn, tranny mounts could be contributing but I doubt that’s the culprit of all this. Annoyed.
 

Forum statistics

Threads
103,891
Messages
1,146,008
Members
13,691
Latest member
dodas

Members online

No members online now.
Top