Switchback led issues

19 SHO

New Member
Joined
May 2, 2021
Messages
6
Reaction score
0
Location
Airdrie
Has anyone had any luck swapping out the front signals to led switchbacks? I've tried 2 different brands and they work for the first time I run the car after the swap and then won't flash at all. No issues using straight amber led's however. I've done the light out change in forscan to stop the hyper flash, just not sure if the SHO likes the switchbacks.
 

Nova

SHO Member
Joined
Jul 27, 2018
Messages
547
Reaction score
900
Location
US
I have switchbacks and turned off the hylerflash in forscan and everything works perfectly on my SHO.
 

Velvet SHO

New Member
Joined
Dec 7, 2019
Messages
7
Reaction score
14
Location
Lincoln, NE
I used the Lasfit 3157 white/amber CANBUS switchbacks in mine. Grabbed them off Fleabay. Aside from the amber being ridiculously bright, no issues.
 

FiveLeeter918

Ortiz Performance Sales
Sponsoring Vendor
Joined
May 22, 2017
Messages
2,350
Reaction score
2,849
Location
Tulsa, OK
Last edited:

Adamhj

New Member
Joined
Oct 24, 2022
Messages
7
Reaction score
1
Location
Dallas TX
I bought these 3157 LED switchbacks from AUXITO go into the parking lot and turn signal socket in my 20 SHO. The entire install was a breeze, gasket tightness, electrical plug, no clearance issues inside or outside the housing at least on my car. They work great! I didn’t get a picture of them in use from white to amber. If you don’t have a drl wore running into your turn signal outlet they won’t work, if you do they will.
1666607131525
 

J persons

New Member
Joined
Apr 20, 2022
Messages
27
Reaction score
11
Location
Natchitoches, LA
These are for the switchers for the front:

3157 Led Bulbs Error Free Canbus... https://www.amazon.com/dp/B0823XC5WW?ref=ppx_pop_mob_ap_share


Sent from my iPhone using Tapatalk
I just tried these led's, when first turned on they would hyper flash then settle down to a regular flash. I tried leaving them on and they would flash but revert to hyper flash then back to regular flash rate. Went back to incandescent until I can find some that work. correctly.
 

yaycandy

Aerospace Engineer
Joined
Jul 2, 2018
Messages
2,170
Reaction score
1,508
Location
Hanover, PA
I just tried these led's, when first turned on they would hyper flash then settle down to a regular flash. I tried leaving them on and they would flash but revert to hyper flash then back to regular flash rate. Went back to incandescent until I can find some that work. correctly.
Can you add a 50w 6ohm load resistor. I havent dun it on this platform but thats usually what it needs. Thats what ja get with cheap conversions that dont have them built in. Usually takes a 2$ component added in to make it work real well.
 

SeanDev

SHO Member
Joined
Jun 6, 2021
Messages
476
Reaction score
368
Location
46131
Can you add a 50w 6ohm load resistor. I havent dun it on this platform but thats usually what it needs. Thats what ja get with cheap conversions that dont have them built in. Usually takes a 2$ component added in to make it work real well.
Did that when I converted my interceptor to HID. 7 years no flash, got to mount them in a metal backed placed, they get very very hot.
 
Top