NEED HELP-Smoking at Extended Idle

NiteSHO

New Member
Joined
Apr 30, 2015
Messages
10
Reaction score
2
I have a 2013 SHH pp. with smoking issues at extended idle. I first did the TSB Update, still smoked. So I replaced both turbos a little over 1000 miles ago. Still smoking at extended idle. Had tech pull downpipes to verify I didn’t get a bad turbo. Both turbos where dry but the cat on the passenger side (side with previous bad turbo) was breaking apart (that explains P0420). Assumed that was my issue. Just installed PPE catted downpipes and it is still smoking. Car has new turbos, gearhead tune and intercooler, PPE catted downpipes 3rd cat delete and resonators. Car runs strong with no check engine lights but at extended idle I get a white plume of smoke out right bank. Doesn’t smell like coolant, oil or gas. Dry black soot in tailpipe. Fluids all look clean. Any ideas?
 

luigisho

SHO Member
Joined
Nov 2, 2001
Messages
12,200
Reaction score
4,266
Location
va beach,va
Usually black in the tailpipe is oil or unburned fuel. Not sure where the smoke is coming from. Maybe you're getting some blow by or the valves got gummed up and aren't sealing great?
 

Lerensho

New Member
Joined
Apr 8, 2022
Messages
12
Reaction score
1
Location
Ontario
I have a 2013 SHH pp. with smoking issues at extended idle. I first did the TSB Update, still smoked. So I replaced both turbos a little over 1000 miles ago. Still smoking at extended idle. Had tech pull downpipes to verify I didn’t get a bad turbo. Both turbos where dry but the cat on the passenger side (side with previous bad turbo) was breaking apart (that explains P0420). Assumed that was my issue. Just installed PPE catted downpipes and it is still smoking. Car has new turbos, gearhead tune and intercooler, PPE catted downpipes 3rd cat delete and resonators. Car runs strong with no check engine lights but at extended idle I get a white plume of smoke out right bank. Doesn’t smell like coolant, oil or gas. Dry black soot in tailpipe. Fluids all look clean. Any ideas?
Hey,
I’m having this issue now, where you able to figure anything out?
 
Top