Custom 3.5L Yamaha

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

Toolman

Boost it!
Club Mod
Joined
Jan 28, 2001
Messages
6,701
Reaction score
3,133
Location
Grand Lake, Oklahoma, USA
Unfortunately, there is some issue with the oil pump or oiling system. Twice now, shortly after firing up, enough pressure builds up that my front main violently pops open and oil gushes out of the engine. I truly have no clear idea as to why.

I paid very decent coin for this built engine, it is quite upsetting that as of now it seems to be a large paperweight. So, it is getting pulled this weekend and a stockish 3.2 ia going in its place. Hopefully I can diagnose something once I have the engine on a stand.

Stay tuned.
 

luigisho

SHO Member
Joined
Nov 2, 2001
Messages
12,786
Reaction score
4,732
Location
va beach,va
Was this an unused custom engine or did it get pulled from a hillclimb car? Looking forward to diagnosis. Sucks that a one off didn't get to be driven for a good while.
 

Toolman

Boost it!
Club Mod
Joined
Jan 28, 2001
Messages
6,701
Reaction score
3,133
Location
Grand Lake, Oklahoma, USA
Was this an unused custom engine or did it get pulled from a hillclimb car? Looking forward to diagnosis. Sucks that a one off didn't get to be driven for a good while.
It was ran in the hill climb vehicle, but was losing oil pressure so it was rebuilt. Found out the chroming to the offset ground crank was insufficient. So it was torn down and rebuilt. This rebuilt engine was never put back in the vehicle. I wish it had been though as now I’m stuck with diagnosing what the engine builder missed.

But I’m wondering if something is wrong with the oiling system now, as it has twice blown out the front main from over pressure. Just removed pump and this is what it looks like inside, and I would think the assembly **** would have been washed out if oiling system was actually operating as it should. I’m at a loss.
 

Attachments

  • IMG_4823.jpeg
    IMG_4823.jpeg
    213.9 KB · Views: 13

luigisho

SHO Member
Joined
Nov 2, 2001
Messages
12,786
Reaction score
4,732
Location
va beach,va
Huh. I wonder is it original oem pump, pickup etc or did they go with a higher pressure or capacity pump? One of one you never know unless you have everything listed and maybe explained if it's in industy lingo that you're not used to seeing. You get this from Todd or someone else in that community?
 

Toolman

Boost it!
Club Mod
Joined
Jan 28, 2001
Messages
6,701
Reaction score
3,133
Location
Grand Lake, Oklahoma, USA
From Todd. He did not list anything about pump. Also looks like screws have never been turned. A few on FB are thinking too much **** was issue. I’m not so sure. But I might put back together and see what happens.
 

Toolman

Boost it!
Club Mod
Joined
Jan 28, 2001
Messages
6,701
Reaction score
3,133
Location
Grand Lake, Oklahoma, USA
Have you pulled a valve cover to see if you’re getting oil up top?
Going to swap out a known running 3.2, just so I can do my track day Friday. But before convention I’ll be doing further diagnosing. This engine has extra oiling lines running to the heads also. So I’ll need to make sure those are clogged up.
 
Back
Top