98 crank no start

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

WilliamNakutis

New Member
Joined
Jun 9, 2024
Messages
1
Reaction score
0
Location
North Carolina
I recently bought a 98 SHO that has been sitting for several years. i changed the fuel pump and it started and ran for 100 or so miles, then it cut off driving down the road and now it wont start. After it cut off on me I replaced the fuel filter with no luck starting, then I replaced the fuel pump again thinking that maybe the dirty filter made the pump run too hard and messed it up, Again it didnt start. If i spray starter fluid in the intake itll start but cut back off. can someone please give me some guidance on what the problem is or could be?
 

Texas Marauder

SHO Member
Joined
Jul 20, 2007
Messages
351
Reaction score
323
Location
Out there somewhere
Things you can do with no tools. Check if the inertia switch is tripped. Also, there should be a fuel pump relay in the engine fuse box. Swap it with a like relay. Check fuse 10, powers the fuel pump relay, in the underhood fuse box.

 
Last edited:

SHOrod

Torrie Tuned
Joined
Jan 1, 2006
Messages
1,059
Reaction score
408
Location
Cedar Rapids, IA
Do you have the tools to be able to determine if you have fuel pressure but no injector pulse, or the opposite (pulse but no pressure)?

-Rod
 

fcable

New Member
Joined
Jan 27, 2024
Messages
17
Reaction score
9
Location
Carrollton Georgia
I recently bought a 98 SHO that has been sitting for several years. i changed the fuel pump and it started and ran for 100 or so miles, then it cut off driving down the road and now it wont start. After it cut off on me I replaced the fuel filter with no luck starting, then I replaced the fuel pump again thinking that maybe the dirty filter made the pump run too hard and messed it up, Again it didnt start. If i spray starter fluid in the intake itll start but cut back off. can someone please give me some guidance on what the problem is or could be?
Can you hear the fuel pump run when you first turn the key to "on"? Don't turn it to "start". When you turn the key to "on", you should hear the pump run for 2-3 seconds.
 

SHOdded

SHO Member
Joined
Dec 25, 2011
Messages
8,933
Reaction score
4,266
Location
Maryland
most likely gummed up injectors. common with cars that have been sitting too long. an induction service is likely the quickest way to recover from this but a fresh tank of fuel with techron concentrate plus or bg 44k in it should work too just take longer. i would try new fuel first.

hopefully the fuel system otherwise is fine as per the posts above.
 

Forum statistics

Threads
105,620
Messages
1,165,376
Members
14,954
Latest member
ddizzy81

Members online

Back
Top