Went the Stainless Works route

Discussion in 'Generation 4 - Performance Upgrades' started by The Gemini, Sep 30, 2019.

  1. The Gemini

    The Gemini Member

    Joined:
    Jun 22, 2016
    Messages:
    65
    Likes Received:
    41
    Gender:
    Male
    Location:
    Ohio
    I guess you can call this a follow-up thread to my "Which Exhaust?" thread from a month ago or so.

    I decided to go with the Stainless Works catted downpipes and cat-back exhaust system. I just really liked what I heard on their channel for the complete set-up on a SHO, and the fact that they are located in my home state sealed the deal for me.

    I am extremely glad I got this system, and absolutely love the way my car sounds now. Here's a posted video:



    Yes, it's a pricey system. Yes, I have a CEL on all the time now. Yes, there were a couple minor issues right out of the box. However, I worked with Dean at SW, and he made sure I was taken care of. Helped me out from start to finish, and always got right back to me on any questions I needed help with.


    Again, I am completely happy with this set-up. Please let me know your thoughts.


    II
     
    Last edited: Sep 30, 2019
  2. SM105K

    SM105K Land Yacht Pilot Supporting Member

    Joined:
    May 3, 2018
    Messages:
    2,157
    Likes Received:
    2,076
    Gender:
    Male
    Occupation:
    Paper Slayer
    Location:
    Arizona
    What is the CEL pretaining too?
     
  3. The Gemini

    The Gemini Member

    Joined:
    Jun 22, 2016
    Messages:
    65
    Likes Received:
    41
    Gender:
    Male
    Location:
    Ohio
    I don’t remember the exact code right now (I’ll get it in the morning and post), but it’s tied to the high flow cats / temp sensor. I’ve been told this happens with a lot of aftermarket cat con’s, including the SW.
     
  4. SM105K

    SM105K Land Yacht Pilot Supporting Member

    Joined:
    May 3, 2018
    Messages:
    2,157
    Likes Received:
    2,076
    Gender:
    Male
    Occupation:
    Paper Slayer
    Location:
    Arizona
    Have your tuner tune it out.
     
  5. chrisjobe

    chrisjobe Member Supporting Member

    Joined:
    Nov 3, 2016
    Messages:
    67
    Likes Received:
    35
    Gender:
    Male
    Occupation:
    Systems Engineer
    Location:
    Williamsburg, VA
    Home Page:
    SHOdded likes this.
  6. The Gemini

    The Gemini Member

    Joined:
    Jun 22, 2016
    Messages:
    65
    Likes Received:
    41
    Gender:
    Male
    Location:
    Ohio
    The exact code for the CEL is: P0141 / O2 Sensor Heater Circuit Bank 1 Sensor 2

    Confirmed my tuner won't turn off the CEL due to emission laws.


    II
     
  7. FiveLeeter918

    FiveLeeter918 Ortiz Performance Sales

    Joined:
    May 22, 2017
    Messages:
    194
    Likes Received:
    163
    Gender:
    Male
    Occupation:
    Mechanical Engineer
    Location:
    Tulsa, OK
    Home Page:
    P0141 means that you don't have the rear O2 plugged in. It's an electrical circuit fault.

    After about 50 miles you're going to get a P0420 and P0430 codes for cat efficiency. In my experience even the catted versions from SW pop them.

    As Chris said above though, the Big Daddy's defoulers work great and will get the code eliminated without a tune change.

    What physical issues did you have? We've seen occasionally where the bung for the O2s are deburred and you have to reach in there and knock off some slag that prevents the O2 from being installed, but otherwise no issues.
     
    SHOdded likes this.

Share This Page

If you wish to help keep SHOforum running, please click the donation button below