Three 2013 SHO Problems, Need some help

Discussion in 'Generation 4 - Maintenance & Troubleshooting' started by 996twint, Jul 10, 2017.

  1. 996twint

    996twint SHO Member

    Joined:
    Jul 11, 2010
    Messages:
    6
    Likes Received:
    1
    Location:
    West Palm Beach, FL
    I have a CPO 2013 SHO with 48k miles that just has powertrain warranty left. I have three problems and I'm trying to see if it's something I could fix myself.
    First problem is the A/C fan fluctuates intermittently.
    Second problem is there is a slight surge when driving at a steady speed. If I'm doing 40, it constantly has a very slight surge that you can feel.
    Third problem is when I'm driving in first at slow speed and let off the gas, it noticeably kicks into second very hard. This is the only gear it does it in. Pretty sure this will be covered under my powertrain warranty.
    Any help is appreciated.
     
    Bswizz likes this.
  2. SHOdded

    SHOdded SHO Member

    Joined:
    Dec 25, 2011
    Messages:
    5,572
    Likes Received:
    1,988
    Location:
    Maryland
    1) Blower motor, resistor or HVAC module - generally not an issue on the SHO tho
    2) Surge may be symptomatic of a PTU issue (there is a TSB on it) or a torque converter
    3) ??? bad TSS/OSS sensor(s), valve body, solenoid, clutch
     
  3. JasonoftheRugar

    JasonoftheRugar SHO Member

    Joined:
    Feb 29, 2016
    Messages:
    205
    Likes Received:
    217
    Gender:
    Male
    Occupation:
    Factory-Machining
    Location:
    Wisconsin
    Did you just buy this car? For problem #3. Disconnect the battery connect after 10 min. Let the transmission adapt to your driving.
     
    SHOdded likes this.
  4. 996twint

    996twint SHO Member

    Joined:
    Jul 11, 2010
    Messages:
    6
    Likes Received:
    1
    Location:
    West Palm Beach, FL
    Owned the car for a year and a half.
    I think the surge might be the hose to the MAP sensor by the rear turbo. I've read of a couple of other people that had the same issue.
    Going to take the car in this week to the dealer.
     

Share This Page

If you wish to help keep SHOforum running, please click the donation button below