Sync 3 ver 3.0 update breaks voice control with Fix

Discussion in 'Generation 4 - General Discusson' started by tech10002, Jul 19, 2018.

  1. tech10002

    tech10002 SHO Member

    Joined:
    Aug 17, 2011
    Messages:
    328
    Likes Received:
    296
    Location:
    Kentucky
    795E1D1D-B5F7-41D3-AC1C-2A33A9E3FC1E.jpeg A little venting plus a fix...

    So I updated Sync 3 to the official version 3 off the syncmyride website in the SHO to get Waze working with the Ford Alexa app. I updated my wife’s Flex a couple months ago, and it worked fine. After letting it do its thing and say the update finished, rebooting, and then letting it finish again just like the Flex, the update appeared to work. It said version 3.0 on the about screen. When I drove it yesterday I used nav for the first time since the update. There were no nav voice prompts, and the voice control button didn’t work giving me an error message saying “voice recognition not ready.” I read a bunch of posts on various Ford forums and this seems like a common issue and people had it solved by having the dealer update their APIM.

    I dropped it off at the dealer and this is what I get back. ^^^^ They said since I was already at version. 3.0, they couldn’t update it since that was the current version. Surely dealers can force an update with IDS. They also said version 3 didn’t work at all, and were willing to do nothing. That’s kinda funny because thousands of people are running 3.0 with no problems. I asked if you can’t fix it, then change the APIM and write the software to it. They talked to me like I was an idiot and said that wouldn’t work because it was already at 3.0 and they couldn’t update if I had the current version and Ford wouldn’t authorize it anyway. Doesn’t the Sync software write to the APIM so changing it would revert to a blank unit ready for software? Basically, they said I was SOL and go away. I can’t believe the incompetence at dealers. I spent an hour reading on the F150 forum and found an old thread showing how to roll back to version 2.2 from the leaked 3.0 from earlier this year. I did that to my corrupted official 3.0 and now it’s working fine. I feel like taking it back to those idiots and showing them it’s working where they said there was no fix. Pretty sad when you have a car under warranty and you have to fix it yourself.

    Anyway, if anybody else has this problem on a nav equipped Sync 3, roll back to 2.2 with this file. https://docs.google.com/uc?export=download&confirm=wvQm&id=0ByldYbWwjAf4VXpfdnVNNlVjdzg
    Then you can retry the update to 3.0. You can do it on non nav units too, but it’s much more complex and involves editing the config files. I’m not sure if you can post links to other forums here, so just search for a thread on the F150 forum detailing how called
    HOWTO Downgrade Sync3 v3.0 back to Ford Official v2.2 (build 17011).
     
    SHOdded and Lostneye like this.
  2. Johnbigdog

    Johnbigdog SHO Member

    Joined:
    Feb 17, 2017
    Messages:
    835
    Likes Received:
    917
    Gender:
    Male
    Location:
    michigain
    There have been problems with voice recognition not ready. I'm being told that the software is not being loaded properly to the apim. You can update the apim again to version 3.0 it may help otherwise it's apim time. Go to another dealership.

    On a side note, there is/was a fault with some other errors unrelated to this error that could prevent a dealer from updating sync. Not sure if this is what your dealership experienced.

    I'll investigate further.
     
    SHOdded likes this.
  3. Johnbigdog

    Johnbigdog SHO Member

    Joined:
    Feb 17, 2017
    Messages:
    835
    Likes Received:
    917
    Gender:
    Male
    Location:
    michigain
    Looks like my resources are saying your "voice recognition not ready" message is being blamed on a server error on Ford's end. Dealerships are being told to hold off on trying to re-update the apim unroll another message is being released.

    So even if the apim is replaced, you could still have the same failure.

    Once ford fixes the issue performing standard sync programming should fix this.

    You can try the update again if you want. No garuntees it will be good.
     
    EcoBoostSHO and SHOdded like this.
  4. Lostneye

    Lostneye SHO Member

    Joined:
    Feb 23, 2017
    Messages:
    1,070
    Likes Received:
    876
    Gender:
    Male
    Location:
    NY
    You just have some luck with SYNC 3.

    I have updated 2 junk yard SYNC 3 APIMs with the version 3.0 off 4d Tech's website without issues both were at 1.0 when I started. My only issue is occasionally the nav APIM will disconnect Bluetooth with my phone if it's plugged in using carplay and I unplug it while driving. I had no issues with the non nav APIM before I swapped the nav one in.
     
  5. EcoBoostSHO

    EcoBoostSHO SHO Member

    Joined:
    Jan 12, 2012
    Messages:
    147
    Likes Received:
    102
    Location:
    Minnesota
    I have this same issue. Just updated to Sync 3 with an APIM from a 17 explorer (on 2013 SHO) and just lost the voice button. Hopefully they will release an update.

    Sent from my XT1650 using Tapatalk
     
  6. Johnbigdog

    Johnbigdog SHO Member

    Joined:
    Feb 17, 2017
    Messages:
    835
    Likes Received:
    917
    Gender:
    Male
    Location:
    michigain
    Nope, projected future is 3.0. There will be updates, but the level is at 3.0. Working on the next generations already.

    You will have to have a dealership reinstall 3.0.
     
  7. EcoBoostSHO

    EcoBoostSHO SHO Member

    Joined:
    Jan 12, 2012
    Messages:
    147
    Likes Received:
    102
    Location:
    Minnesota
    I actually just did a master reset and everything is working now!

    Sent from my XT1650 using Tapatalk
     
  8. Johnbigdog

    Johnbigdog SHO Member

    Joined:
    Feb 17, 2017
    Messages:
    835
    Likes Received:
    917
    Gender:
    Male
    Location:
    michigain
    Sweet!

    The biggest problem with the voice recognition not ready is the files being downloaded be g corrupted.

    I also just remembered. Give sync 5 minute after shut down to turn the key on. This will give the system time to start running the new software properly or something like that. Shut down and restart are causing problems too.
     
    EcoBoostSHO likes this.
  9. tech10002

    tech10002 SHO Member

    Joined:
    Aug 17, 2011
    Messages:
    328
    Likes Received:
    296
    Location:
    Kentucky
    Try the file I mentioned above and roll back to 2.2. That will get your voice working again, and then retry the update to 3.0. I can’t believe Ford is telling dealers to send customers away with a broken system. I travel through several states frequently where it’s illegal to hold the phone up to your ear, so the voice commands have to work.
     
  10. Darold A Lowe

    Darold A Lowe New Member

    Joined:
    Apr 5, 2019
    Messages:
    6
    Likes Received:
    0
    Gender:
    Male
    Location:
    Reedsville, PA
     
  11. Darold A Lowe

    Darold A Lowe New Member

    Joined:
    Apr 5, 2019
    Messages:
    6
    Likes Received:
    0
    Gender:
    Male
    Location:
    Reedsville, PA
    I downloaded the zip file, can you please point me to or give me instructions as to how to actually use the file to rollback to version 2.2. Thank you so much. My car is actually a 2016 Lincoln MKC that is out of warranty. Today I took the car to my local dealership who charged me $107 to diagnose and said that "A NEW APIM WILL BE REQUIRED TO FIX ISSUE" they quoted me a price of $767.35 to have that done. Since this is a SERIOUS SAFETY concern that was caused by their update I feel that they should do whatever needs done at NO CHARGE. I will be seeking legal council and have opened a case with Lincoln Motor Company Client Relationship Center.
     
  12. SHOdded

    SHOdded SHO Member Supporting Member

    Joined:
    Dec 25, 2011
    Messages:
    7,683
    Likes Received:
    3,308
    Location:
    Maryland
    Not sure how this is a safety concern, but I do wish you the best of luck with getting a resolution. Talking directly with Lincoln Customer Service can often yield results.
     
    Christian likes this.
  13. Johnbigdog

    Johnbigdog SHO Member

    Joined:
    Feb 17, 2017
    Messages:
    835
    Likes Received:
    917
    Gender:
    Male
    Location:
    michigain
    This message is cause by the language pa k not being fully installed during programming.

    It may be resolved by firing standard programming of the apim by the dealership again using a different USB drive.

    If you roll back, and then try programming again allowing 5 minuets of key off time, the apim may be salvageable. The caveat is the dealership does not have a way to go backwards in programing.
     
    Darold A Lowe and Lostneye like this.
  14. Darold A Lowe

    Darold A Lowe New Member

    Joined:
    Apr 5, 2019
    Messages:
    6
    Likes Received:
    0
    Gender:
    Male
    Location:
    Reedsville, PA
    Thank you for your reply.
    I will try the roll back and keep my fingers crossed.
    I don't know why Ford refuses to repair the software and insists on
    replacing the hardware. I can only assume the new APIM hardware must come
    pre-loaded with the software.
    Very expensive solution to such a simple problem
     
  15. Johnbigdog

    Johnbigdog SHO Member

    Joined:
    Feb 17, 2017
    Messages:
    835
    Likes Received:
    917
    Gender:
    Male
    Location:
    michigain
    Yes the new APIM will come with the latest software. This also includes map data as well from my understanding.

    The dealership is really limited to how Ford builds the process which is expensive in this instance. Calling lincon concierge is a good idea.
     
    Darold A Lowe likes this.
  16. jmr061

    jmr061 SHO Member

    Joined:
    Jan 23, 2013
    Messages:
    265
    Likes Received:
    83
    Location:
    WI
    Do a complete format of your USB, reload the software onto the USB

    Master reset SYNC and re-run the upgrade.
     
    Darold A Lowe and Lostneye like this.
  17. Lostneye

    Lostneye SHO Member

    Joined:
    Feb 23, 2017
    Messages:
    1,070
    Likes Received:
    876
    Gender:
    Male
    Location:
    NY
    This. And if that doesn't work I would just buy an APIM from a yard and program using forscan.
     
    Darold A Lowe likes this.
  18. Darold A Lowe

    Darold A Lowe New Member

    Joined:
    Apr 5, 2019
    Messages:
    6
    Likes Received:
    0
    Gender:
    Male
    Location:
    Reedsville, PA
    How difficult is it to install the APIM and where do you get the "forscan" ?
     
  19. Roger Batts

    Roger Batts Member

    Joined:
    Sep 26, 2017
    Messages:
    72
    Likes Received:
    51
    Gender:
    Male
    Occupation:
    North Central Ford Parts Sales
    Location:
    Dallas/Ft Worth Area
    https://forscan.org/ You will need to register and request an extended license to access SYNC features.
     
    Darold A Lowe and Lostneye like this.
  20. Lostneye

    Lostneye SHO Member

    Joined:
    Feb 23, 2017
    Messages:
    1,070
    Likes Received:
    876
    Gender:
    Male
    Location:
    NY
    The APIM is on the back of the screen. It's more involved than hard since a lot of pieces need to come off to get the screen trim/control panel/center vents off. You will only need forscan if the APIM came from a car with different relevant options than yours. For example if you have heated and cooled seats and the donor car only had heated front seats you will have to update the APIM to have the correct options on the screen. You will also need an OBD II connector with wifi or USB to connect to your computer to use forscan.
     
    SHOdded and Darold A Lowe like this.

Share This Page

If you wish to help keep SHOforum running, please click the donation button below