Switchback issue: amber flickers while car is running

Discussion in 'Generation 4 - Exterior Mods' started by TBEcoSho, May 16, 2020.

  1. TBEcoSho

    TBEcoSho New Member

    Joined:
    Nov 1, 2019
    Messages:
    9
    Likes Received:
    0
    Gender:
    Male
    Location:
    Valparaiso Indiana
    Hey guys,
    So I just got my switchbacks installed with the recommended load resistors to prevent the hyperflashing. The only issue I'm having is that while the car is running the amber turn signal flickers while flashing. This happens in all conditions and also when the hazards are on. This does not happen when the car is shut off. Any ideas?
     
  2. High on Ethanol

    High on Ethanol SHO Member

    Joined:
    Aug 3, 2019
    Messages:
    395
    Likes Received:
    311
    Gender:
    Male
    Occupation:
    Project Manager
    Location:
    USA
    Try Forscan. If that fails try different bulb brands. I remember having that problem as well and it took several tries to get it working.
     
  3. FiveLeeter918

    FiveLeeter918 Ortiz Performance Sales Sponsoring Vendor Supporting Member

    Joined:
    May 22, 2017
    Messages:
    867
    Likes Received:
    933
    Gender:
    Male
    Occupation:
    Mechanical Engineer
    Location:
    Tulsa, OK
    Home Page:
    having a similar issue with mine. I used forscan to disable the turn signal hyperflash, but find that if the car is on and I unlock the car, the ambers will flicker.
     
  4. TBEcoSho

    TBEcoSho New Member

    Joined:
    Nov 1, 2019
    Messages:
    9
    Likes Received:
    0
    Gender:
    Male
    Location:
    Valparaiso Indiana
    Pretty annoying. Guess I'll be trying different bulbs
     
  5. 6500rpm

    6500rpm Quality Always Shoots Straight

    Joined:
    Jun 21, 2016
    Messages:
    391
    Likes Received:
    422
    Gender:
    Male
    Occupation:
    Journeyman Fleet Tech
    Location:
    The safe zone outside metro St Louis
    I have had the same issue repeatedly with DriveBright DRL switch backs. White is good all the time, turn signals hyper flash with the engine running. I've replaced multiple modules- some work for a year, some fail right from the box.
     
  6. FiveLeeter918

    FiveLeeter918 Ortiz Performance Sales Sponsoring Vendor Supporting Member

    Joined:
    May 22, 2017
    Messages:
    867
    Likes Received:
    933
    Gender:
    Male
    Occupation:
    Mechanical Engineer
    Location:
    Tulsa, OK
    Home Page:
    yea my understanding is that the pcm is sending alternating signals of 0 and 15v, and the incandescents operating slow enough that they catch the average, but the LEDs are much more sensitive and they are displacing that voltage variance.
     
  7. TBEcoSho

    TBEcoSho New Member

    Joined:
    Nov 1, 2019
    Messages:
    9
    Likes Received:
    0
    Gender:
    Male
    Location:
    Valparaiso Indiana
    So what is the solution to this? And why is it only happening with the engine running?
     
  8. FiveLeeter918

    FiveLeeter918 Ortiz Performance Sales Sponsoring Vendor Supporting Member

    Joined:
    May 22, 2017
    Messages:
    867
    Likes Received:
    933
    Gender:
    Male
    Occupation:
    Mechanical Engineer
    Location:
    Tulsa, OK
    Home Page:
    haven't found a solution yet short of wiring in a relay to keep constant voltage which I really don't want to do.
     
  9. TBEcoSho

    TBEcoSho New Member

    Joined:
    Nov 1, 2019
    Messages:
    9
    Likes Received:
    0
    Gender:
    Male
    Location:
    Valparaiso Indiana
    Uh no neither do I. Pretty dumb might just have to deal with it.
     
  10. FiveLeeter918

    FiveLeeter918 Ortiz Performance Sales Sponsoring Vendor Supporting Member

    Joined:
    May 22, 2017
    Messages:
    867
    Likes Received:
    933
    Gender:
    Male
    Occupation:
    Mechanical Engineer
    Location:
    Tulsa, OK
    Home Page:
    welp update, today while sitting behind a car at a light I realized that mine too are flickering when using the turn signals. aye...
     
  11. Nova

    Nova SHO Member

    Joined:
    Jul 27, 2018
    Messages:
    152
    Likes Received:
    190
    Location:
    US
    I put leds in my turn signals and noticed they only hyperflash when my headlights are on. So basically they only hyperflash at night, I've also noticed that if I leave the turn signals on while at a light or something that sometimes they will stop hyperflshing and start acting normal and then go back to hyperflash.

    Sent from my SM-G986U using Tapatalk
     
    Last edited: May 20, 2020
  12. High on Ethanol

    High on Ethanol SHO Member

    Joined:
    Aug 3, 2019
    Messages:
    395
    Likes Received:
    311
    Gender:
    Male
    Occupation:
    Project Manager
    Location:
    USA
    I think the ones I used were diode dynamics
     
  13. FiveLeeter918

    FiveLeeter918 Ortiz Performance Sales Sponsoring Vendor Supporting Member

    Joined:
    May 22, 2017
    Messages:
    867
    Likes Received:
    933
    Gender:
    Male
    Occupation:
    Mechanical Engineer
    Location:
    Tulsa, OK
    Home Page:
    That's what mine are
     
  14. 6500rpm

    6500rpm Quality Always Shoots Straight

    Joined:
    Jun 21, 2016
    Messages:
    391
    Likes Received:
    422
    Gender:
    Male
    Occupation:
    Journeyman Fleet Tech
    Location:
    The safe zone outside metro St Louis
    I haven't had time to check, but the 0-15v thing is probably pulse width modulating the alternator. My deal is a little different, I'm running the switch back running lights from Brightlites but the same issue. They've been chasing the issue for some time and told me that only the Taurus was having issues with their system.
     

Share This Page

If you wish to help keep SHOforum running, please click the donation button below