Shudder 2011 SHO, used Shudder fixx.

Discussion in 'Generation 4 - Maintenance & Troubleshooting' started by kgbpackfan, Jan 16, 2021.

  1. kgbpackfan

    kgbpackfan New Member

    Joined:
    Nov 29, 2020
    Messages:
    12
    Likes Received:
    12
    Gender:
    Male
    Location:
    Idaho
    Ok so I bought my SHO about 2 months ago. When I test drove it, I knew it had a little problem with the rpm jumping up and down during light driving. Basically only when the gas is barely pressed. Well after me changing the transmission fluid 2 times, changed spark plugs, made a weep hole in intercooler ( helped let out a lot of gunky oil, car has 185,000 miles, will patch the 1/8th hole up with some fiberglass bondo when I feel most the oil is out) it still is shuddering while light driving. Its annoying but it still can drive just fine. But after looking into it, it probably is the Torque Converter. So I went and got 2 tubes of Shudder Fixx. I only drove it about 25 miles so far. The last 10 miles I have not noticed any rpm's jumping. So this could be a short term fix or a long term fix. I will have to see. Ill try to update for sure. Just crazy how a $10 tube (x2) could make a big drivetrain part start working right.
     
  2. DGrot777

    DGrot777 Member

    Joined:
    Apr 16, 2020
    Messages:
    30
    Likes Received:
    16
    Gender:
    Male
    Location:
    Michigan
    I'm definitely going with torque converter given your mileage and scenario. I'm honestly thinking about doing a weep hole for my intercooler since I live in a humid area and my issue seems to happen even on newer cars. How's your transmission fluid level right now? Heard these cars are extra picky.
     
  3. kgbpackfan

    kgbpackfan New Member

    Joined:
    Nov 29, 2020
    Messages:
    12
    Likes Received:
    12
    Gender:
    Male
    Location:
    Idaho
    After my second transmission fluid change its a little past the second line on the dipstick. Yesterday it did still shudder with the rpms. Today I took out the dumb noisemaker, just havent driven it much. Ill see if the rpms jumping up and down go away. If they dont then I dont think its the torque converter. The other things it might be is a turbo going bad, or throttle body sticking or maybe the coil pack. My filter is new. ill drive some more in coming days and pay attention to the rpms. The weep hole has sprayed out a lot of gunk since I did it. Kinda makes me not want to fill the hole up knowing the gunk does come out.
     

Share This Page

If you wish to help keep SHOforum running, please click the donation button below