1. lawyerdement

    lawyerdement Member

    Joined:
    Mar 22, 2012
    Messages:
    33
    Likes Received:
    2
    Location:
    TN
    I'm having trouble with the rear camera. The image is scrambled. The lens is not dirty and it's not a lighting issue. It seems like an electronic or computer issue. Any ideas?
     
  2. SHOrod

    SHOrod Torrie Tuned

    Joined:
    Jan 1, 2006
    Messages:
    790
    Likes Received:
    204
    Occupation:
    Sr. Engineering Manager at datalink company
    Location:
    Cedar Rapids, IA
    I just read on another forum about a guy with a 2010 Limited that has a blurry camera image that is not due to the lens. He has a new camera on order and will be installing it soon. It will be interesting to hear if that fixes his.

    Is your display in the center dash or in the rearview mirror? If in the dash, does everything else look fine (radio, climate controls, navigation)?

    -Rod
     
  3. SHOdded

    SHOdded SHO Member Supporting Member

    Joined:
    Dec 25, 2011
    Messages:
    8,286
    Likes Received:
    3,689
    Location:
    Maryland
    If the new camera does not fix the issue, you may need a software patch from Ford. The dealer may not have it available locally.
     
  4. lawyerdement

    lawyerdement Member

    Joined:
    Mar 22, 2012
    Messages:
    33
    Likes Received:
    2
    Location:
    TN
    The display is in the center console. The display seemed fine. It's only fuzzy when in reverse.
     
  5. SHOdded

    SHOdded SHO Member Supporting Member

    Joined:
    Dec 25, 2011
    Messages:
    8,286
    Likes Received:
    3,689
    Location:
    Maryland
    Have the dealer contact Ford for any software patches. Also make sure your MFT is up to date.
     
  6. lawyerdement

    lawyerdement Member

    Joined:
    Mar 22, 2012
    Messages:
    33
    Likes Received:
    2
    Location:
    TN
    I unplugged and replugged the wiring connection to the camera contained in the trunk lid. That seems to have fixed the problem.
     
  7. skyshadow07

    skyshadow07 SHO Member

    Joined:
    Nov 15, 2019
    Messages:
    94
    Likes Received:
    20
    Gender:
    Male
    Location:
    Oklahoma
    Is it something like this that the thread is about? I know this is a dead thread but my rear camera looks like garbage. Yes, the lens is completely clean.
     

    Attached Files:

  8. Majestic

    Majestic SHO Member

    Joined:
    Aug 28, 2016
    Messages:
    392
    Likes Received:
    305
    Gender:
    Male
    I replaced just the camera itself and it is a lot clearer. You can search my posts and all of the details are there. I don't know if the camera is still available.
     
  9. skyshadow07

    skyshadow07 SHO Member

    Joined:
    Nov 15, 2019
    Messages:
    94
    Likes Received:
    20
    Gender:
    Male
    Location:
    Oklahoma
    With just an OE replacement?
     
  10. Majestic

    Majestic SHO Member

    Joined:
    Aug 28, 2016
    Messages:
    392
    Likes Received:
    305
    Gender:
    Male
  11. Billy VK

    Billy VK Member

    Joined:
    Aug 18, 2018
    Messages:
    56
    Likes Received:
    52
    Gender:
    Male
    Location:
    Indiana
    Yeah, so this is a common issue. I got one better than that for ya. Mine is not only blurry but once in a while the picture is actually upside down.... I have to check to make sure I didn't roll over...
     
    jtreber and skyshadow07 like this.

Share This Page

If you wish to help keep SHOforum running, please click the donation button below