Radiator temperature issue

Discussion in 'Generation 4 - Maintenance & Troubleshooting' started by sanman, Jan 24, 2020.

  1. sanman

    sanman SHO Member

    Joined:
    Aug 5, 2015
    Messages:
    91
    Likes Received:
    47
    Gender:
    Male
    I have a 2015 Ford SHO with a Livernois stock tune. I have Aeroforce gauges that give me the exact data for my car. I went on an errand today and 10 minutes in, I saw my temperature gauge was at 190. Within 10 more minutes it crept up to 230. I installed a 160 degree thermostat when I gave it the Livernois tune, back in 2015. Since then, my temperature would be pinned at 174 degrees - no variation. Anybody have any idea what could be causing the temperature to rise? I haven't had a chance to really look at it, since it just happened tonight, but I did check my antifreeze and it looks good. The radiator fan was working properly. In the beginning of the winter, I did set my tune back to stock, due to problems from the Livernois tune, but I really never noticed a fluctuation in temperature until today. Could it be that the thermostat is stuck closed, or the stock tune doesn't turn on the fans as early as a 93 tune? I'm puzzled, so any help would be appreciated. I think tomorrow I will try and start the motor, take the radiator cap off, and see if the thermostat kicks in at 160.
     
  2. xFallenxCripplex

    xFallenxCripplex SHO Member

    Joined:
    Jul 5, 2016
    Messages:
    424
    Likes Received:
    219
    Gender:
    Male
    I hope it's not a headgasket leak.

    Sent from my Pixel 4 XL using Tapatalk
     
  3. sanman

    sanman SHO Member

    Joined:
    Aug 5, 2015
    Messages:
    91
    Likes Received:
    47
    Gender:
    Male
    Just went out started the motor left running for 30 minutes fans came on at about 170-175 the temp stay at 170-175 seems normal again. The car is not driven much 22,000. miles since 2015 change oil every 3-4 thousand miles full syn. I baby the car so pretty sure head gasket is fine, i'm thinking the thermostat was stuck closed heard the 160 thermostats are finecky.. Will take the car for a drive tomorrow to monitor temp. See what happens. Anyone have that happen stuck thermostat? If i need to change the thermostat what temp? I'm thinking 170 or 180 heard 160 is no good for everyday driving....Thanks
     
    citysmoke likes this.
  4. ridered74

    ridered74 SHO Member

    Joined:
    Mar 27, 2015
    Messages:
    509
    Likes Received:
    593
    Gender:
    Male
    I had my LMS thermostat stick one time a month or two after I installed it. It's in its second SHO 4 years later and hasn't stuck again since that one time.
     
    SHOdded and sanman like this.
  5. sanman

    sanman SHO Member

    Joined:
    Aug 5, 2015
    Messages:
    91
    Likes Received:
    47
    Gender:
    Male
    Thanks for letting me know. I'm going with that all good since.
     

Share This Page

If you wish to help keep SHOforum running, please click the donation button below