Question on subframe connectors

Discussion in 'Gen 1 & 2 - Suspension, Brakes & Body' started by SHOYAMAHA, Jan 21, 2019.

  1. luigisho

    luigisho SHO Member

    Joined:
    Nov 2, 2001
    Messages:
    9,467
    Likes Received:
    2,297
    Location:
    va beach,va
    Home Page:
    Old timers in the house!
     
  2. RonPorter

    RonPorter Old Dude

    Joined:
    Feb 25, 2001
    Messages:
    3,127
    Likes Received:
    2,097
    Gender:
    Male
    Occupation:
    Retired!
    Location:
    Lake Orion, MI
    Hi David, welcome back
     
  3. zoomlater

    zoomlater SHO Member Supporting Member

    Joined:
    May 31, 2004
    Messages:
    1,818
    Likes Received:
    1,019
    Location:
    Seattle, WA
    Here is another picture of installed subframe connectors. Mike at Shosource did my installs as well. The last set he did was on my 92 that had rust proof undercoating that kept catching fire and melting all over the place. Fun times!
     

    Attached Files:

    SHOdded and blk\blk90 like this.
  4. SHOMON

    SHOMON 95 MTX Supporting Member

    Joined:
    Aug 15, 2006
    Messages:
    617
    Likes Received:
    112
    Gender:
    Male
    Location:
    MEDWAY MASS.
    Hey Zoom which y-pipe is that??
     
  5. zoomlater

    zoomlater SHO Member Supporting Member

    Joined:
    May 31, 2004
    Messages:
    1,818
    Likes Received:
    1,019
    Location:
    Seattle, WA
    It's not my car, I grabbed the photo off of the web
    It could be a Performance Plus pipe
     
  6. dbonds

    dbonds New Member

    Joined:
    Feb 26, 2011
    Messages:
    29
    Likes Received:
    7
    Location:
    Texas
    Been lurking here for quite awhile. Still driving my 2014 PP with 130k. Toying with idea of watching for a driver quality gen1 or gen2 as a play car. :)
     
    SHOdded and RonPorter like this.

Share This Page

If you wish to help keep SHOforum running, please click the donation button below