New to forum

Daryl Friedrichs

New Member
Joined
Jun 8, 2021
Messages
8
Reaction score
2
Location
Minneota Minnesota
Daryl Friedrichs 2010 candy red metallic. I absolutely love my SHO or as my nine year old puts it, our super high output. It's been a love hate relationship with the turbos which went out at about 135000 miles they were replaced at a big expense then went out again at or before 140000 miles which were replaced under warranty. Now at 165000 they are out again. So I purchased cartridges for both and will soon be putting them in. I change oil religiously every 3500, let car run for a minute before shutting down. There has to be better turbos or parts out there any advice is welcome
 

Daryl Friedrichs

New Member
Joined
Jun 8, 2021
Messages
8
Reaction score
2
Location
Minneota Minnesota
Thank you for adding me. I have a 2010 SHO. Absolutely love this car but the turbos are love/hate. Bought used with 100;000 miles replaced turbos at 135;000 then again under warranty around 142;000 now @165;000 out again so I am going to put new cartridges in myself, any advice or tips would be awesome!!! I change oil every 3500 miles and let run a minute or two before turning off. I'm going to switch from 5w20 to 5w30 when cartridges go in. Any tips on removing turbos greatly appreciated.
 

gwrabbit

SHO Member
Joined
May 22, 2019
Messages
120
Reaction score
106
Location
Wisconsin
2 turbo failures within 10k miles would have me concerned.

Have you checked for any leaks? How is the water pump and timing chain?
 

Daryl Friedrichs

New Member
Joined
Jun 8, 2021
Messages
8
Reaction score
2
Location
Minneota Minnesota
2 turbo failures within 10k miles would have me concerned.

Have you checked for any leaks? How is the water pump and timing chain?
Have not found any leaks even took bottom engine bay cover off to watch for drips. Water pump and timing chain seem fine. I'm guessing cheap rebuilds were used instead of (brand new). Seems like I saw others with same issue. They are currently leaking oil on exhaust side I assume by the blue cloud from exhaust. Loss of power was first sign then a short belt type squeel followed later by blue smoke.
 

Jordan_R

Stock Block Ready To Knock...er..Rock
Joined
Sep 20, 2017
Messages
1,431
Reaction score
3,151
Location
Missouri
Did you replace the feed lines on the turbos/clean the screens in them?
 

Latest posts

Forum statistics

Threads
102,522
Messages
1,131,303
Members
12,686
Latest member
lesleyberge

Members online

No members online now.
Top