1. plumber

    plumber SHO Member

    Joined:
    Apr 16, 2009
    Messages:
    91
    Likes Received:
    8
    Location:
    mi.
    Hello. Well I have a new problem. As you may know I had issues that turned out to have me changing first the ccrm (new from shosource) and then the ecm. The car has been running great for 4 months. The last week the fp would stay on until the car started. Then the fp started shutting off like it should. Now when the key is in start position the fp comes on and stops like it should but now the radiator fan comes on to but goes off when car is started. So is it a bad ccrm already or ecm. Thanks Plumber
     
  2. zoomlater

    zoomlater SHO Member Supporting Member

    Joined:
    May 31, 2004
    Messages:
    1,520
    Likes Received:
    892
    Location:
    Seattle, WA
    I have the same issue when I turn the key to the on position, the fan comes on. After warming the car up, when I restart it, the fan doesn't come on as soon as I turn the key to the on position. Mike (at Shosource) said it could be the ECM. Now this is on my seldom used car that sits for months without being started, hence I haven't tried a different ECM on it yet.

    I was also reading on this forum, that this could be caused by a ground issue.
     
    Last edited: Jul 21, 2019
  3. plumber

    plumber SHO Member

    Joined:
    Apr 16, 2009
    Messages:
    91
    Likes Received:
    8
    Location:
    mi.
    Thank you for the info. I will see if another ecm helps first. It will be a few days but I will let you know if that solves the problem. Plumber
     
  4. NoSlo

    NoSlo GoldMember

    Joined:
    Aug 21, 2003
    Messages:
    650
    Likes Received:
    430
    Location:
    Portland, OR
    Home Page:
    The radiator fan only runs when the car is hot and needing cooling, as indicated by the temperature sensor. It also runs at full speed instead of half-speed when the AC is on and the engine is warmed up.

    Have you left a jumper in the diagnostic port? This will run all the sensors for a bit when the car starts up, but of course will be indicated by blinking codes on the check engine light.
     
  5. plumber

    plumber SHO Member

    Joined:
    Apr 16, 2009
    Messages:
    91
    Likes Received:
    8
    Location:
    mi.
    Thanks for input. So today I tapped on the new ccrm and everything worked like it should. So now i'm stumped. I will see what happens next. Plumber
     
  6. itwonder

    itwonder SHO Member

    Joined:
    Dec 17, 2005
    Messages:
    1,897
    Likes Received:
    537
    Location:
    VA
    The fan runs when the either the coolant temperature is high or the A/C is on, whenever the car is moving at less than 50 mph. If it's working in those conditions, I would not worry over what happens when the ignition key is cycled.
     

Share This Page

If you wish to help keep SHOforum running, please click the donation button below