Long overdue intro

Roswell M Sutton

New Member
Joined
Aug 24, 2020
Messages
4
Reaction score
1
Location
Atlanta
Hello all , my name is Roswell Sutton. I have actually been registered on this site for over a year but have been going through a lot since the CORONA virus changed a lot of the ways we all live.
I also have been trying to get a SHO I bought in 2005 back on the road again.
It's a 1994 SHO with a 5 speed manual transmission. When I bought it I put about 500 dollars in it to get it going again. I drove it for approximately 5 to 6 months and started having issues with it. Right now it has an issue with slow to respond to throttle. It starts but is real sluggish. I installed a new fuel tank and pump because the original tank and pump were corroded and the pump stopped working. I discovered when it is running the exhaust flow from the left pipe feels normal , but the right side has very little exhaust flow coming from it. I am also having brake problems but I should have that taken care of soon.
Ultimately I am looking for someone who is familiar with the Yamaha 3.0 liter engine to help me get my SHO back in good running condition.
I really love this car. It's fun to drive and is a true 4 door sleeper.
If anyone knows a good SHO mechanic in the greater Atlanta , Cobb , Fayetteville , Jonesboro , McDonough , or Smyrna areas please let me know.
I can be reached at 404-550-6658.

Thanks
Roswell
 

zoomlater

SHO Member
Supporting Member
Joined
May 31, 2004
Messages
2,525
Reaction score
1,308
Location
Seattle, WA
Welcome! Post some pics. Have you pulled your codes to see if there are any stored? Does the car feel like it has a misfire or runs fine, but just sluggish?
 
Last edited:

Roswell M Sutton

New Member
Joined
Aug 24, 2020
Messages
4
Reaction score
1
Location
Atlanta
Welcome! Post some pics. Have you pulled your codes to see if there are any stored? Does the car feel like it has a misfire or runs fine, but just sluggish?
I had a guy several years ago who scanned the engine and said the code pointed to the catalytic converters. They were clogged and breaking down. It starts , idles fine but as you push the gas pedal down the engine RPM lags behind where it should be based on where the pedal is. It will eventually rev up but is just slow to respond to throttle. I have a bad master cylinder that I'm replacing. As soon as I get that done I will take it to get a new exhaust system minus the cats. I hope that will solve the throttle lag. I will post some pictures soon.
 

Roswell M Sutton

New Member
Joined
Aug 24, 2020
Messages
4
Reaction score
1
Location
Atlanta
Welcome! I’m sure there’s some knowledgeable help in your area.
Well I have not found anyone yet. Will keep looking because I would like someone who is familiar with the Yamaha engine to let me know what kind of condition the engine is in. I bought the car in 2005. Drove it a short time before it developed the slow throttle response. It's been sitting up since 2011. Hoping to get it back on the road soon !
 
Top