Engine Sputtering Periodically

Discussion in 'Gen 1 & 2 - Emergency Issues - Help & Maintenance' started by vsofouk, Oct 20, 2020.

  1. vsofouk

    vsofouk New Member

    Joined:
    May 7, 2009
    Messages:
    20
    Likes Received:
    2
    Occupation:
    Ford Service Advisor
    Location:
    Cleveland OH
    Hey everyone, I have an odd issue here.

    After about 20 minutes of driving the car starts sputtering (it feels like it's running on 4-5 of the 6 cylinders). There's no CEL on. If I pull over and immediately try to start it, it will either hesitate and restart with a rough idle, or it will crank and the crank has a dead spot in it like it's catching something.

    After I let it sit for 10-15 minutes, it will start and run just fine. (If I'm on the highway and cut the engine, after about 30-45 seconds of coasting, it will do the same thing) But after another 20 minutes of driving, it will start acting up again.

    Another thing worth mentioning is that after I try to do an immediate restart, the tach won't work until the car either starts acting up again, or if it sits for that 10-15 minutes.

    I've seen some threads about the TPS and the CPS. Do we think it's one of these?
     
  2. luigisho

    luigisho SHO Member

    Joined:
    Nov 2, 2001
    Messages:
    10,547
    Likes Received:
    3,386
    Location:
    va beach,va
    Home Page:
    Sounds like a crank sensor on its way out to me. These are tough to find.
     
  3. zoomlater

    zoomlater SHO Member Supporting Member

    Joined:
    May 31, 2004
    Messages:
    2,194
    Likes Received:
    1,169
    Location:
    Seattle, WA
    Pull your codes. Codes can be set even though there is no check engine light
     
    luigisho likes this.
  4. NoSlo

    NoSlo GoldMember

    Joined:
    Aug 21, 2003
    Messages:
    777
    Likes Received:
    562
    Location:
    Portland, OR
    Home Page:
    Oil in the spark plug wells. Free to temporarily fix.

    If the tach is involved though, dropping to 0, that's a sign of cam position sensor.
     
  5. luigisho

    luigisho SHO Member

    Joined:
    Nov 2, 2001
    Messages:
    10,547
    Likes Received:
    3,386
    Location:
    va beach,va
    Home Page:
  6. BaySHO Performance

    BaySHO Performance SHO Member

    Joined:
    Feb 25, 2001
    Messages:
    364
    Likes Received:
    320
    Location:
    SF South Bay
    Home Page:

Share This Page

If you wish to help keep SHOforum running, please click the donation button below