Blower Motor Issue

Discussion in 'Gen 1 & 2 - Electronics & Audio' started by sperold, Jun 24, 2018.

  1. sperold

    sperold Last to Know

    Joined:
    Aug 25, 2008
    Messages:
    3,267
    Likes Received:
    1,004
    Gender:
    Male
    Occupation:
    Mech. Tech.
    Location:
    Ontario Canada
    The blower motor comes on full when I turn the key to on, before I start the car.
    And this is when the climate system is "OFF"
    And when the car starts, the fan still is on high and never shuts off.

    I have not tried to diagnose it yet, as it defies logic. I have changed a few Blower Control Modules (BCMs) in the past when they only worked in the full or top setting, but I have never had one that came on full even when the climate system is off.

    Let me know if this issue rings a bell with anyone, as it has me stumped right now. Also the issue came out of the blue, with no changes or much of anything happening to the car lately.,

    93 SHO originally ATX, converted to MTX 10 years ago.
     
  2. SHOdded

    SHOdded SHO Member

    Joined:
    Dec 25, 2011
    Messages:
    6,541
    Likes Received:
    2,586
    Location:
    Maryland
    Any codes in the eatc module? Otherwise fuse or short is next on the list.
     
    sperold likes this.
  3. TimboSHO

    TimboSHO Novice

    Joined:
    Aug 22, 2002
    Messages:
    2,202
    Likes Received:
    651
    Location:
    Wyoming, MI
    I had a blower control module do this in my 91. That car had so many issues, I can't remember if there was something else wrong as well, or if that was it. I'm almost certain that it was just the BCM though....
     
    luigisho, SHOdded and sperold like this.
  4. rubydist

    rubydist Moderator Staff Member

    Joined:
    Jun 25, 2007
    Messages:
    6,650
    Likes Received:
    2,418
    Location:
    Denver
    My thought was also blower control module - they have numerous fault symptom possibilities including always on.
     
    luigisho, sperold and SHOdded like this.
  5. BaySHO Performance

    BaySHO Performance SHO Member

    Joined:
    Feb 25, 2001
    Messages:
    124
    Likes Received:
    71
    Location:
    SF South Bay
    Home Page:
    Definitely the Variable Speed Blower Motor Control E9DZ-19E624-A. I had the exact same symptoms on a 95. You might find one on eBay. The only one left in dealer inventory is at Haven Ford, Haven, KS. Now called Haven Auto. (620) 465-2252. www.havenautomotive.com Might be an inventory error.
     
    sperold, luigisho and SHOdded like this.

Share This Page

If you wish to help keep SHOforum running, please click the donation button below