Any help would be great

Purple Sho

Member
Joined
Jul 12, 2021
Messages
64
Reaction score
36
Location
Estancia (outside Albuquerque) New Mexico
You must be registered for see images attach
 

Attachments

  • IMG_20211022_131157.jpg
    IMG_20211022_131157.jpg
    336.8 KB · Views: 20
  • IMG_20211022_131206.jpg
    IMG_20211022_131206.jpg
    355.8 KB · Views: 21
  • IMG_20211022_131213.jpg
    IMG_20211022_131213.jpg
    357 KB · Views: 20
  • IMG_20211022_131221.jpg
    IMG_20211022_131221.jpg
    326 KB · Views: 17
  • IMG_20211022_131227.jpg
    IMG_20211022_131227.jpg
    330.6 KB · Views: 16
  • IMG_20211022_131234.jpg
    IMG_20211022_131234.jpg
    353.5 KB · Views: 15
  • IMG_20211022_131305.jpg
    IMG_20211022_131305.jpg
    327.7 KB · Views: 17

Purple Sho

Member
Joined
Jul 12, 2021
Messages
64
Reaction score
36
Location
Estancia (outside Albuquerque) New Mexico
Theses are all check engine lights I'm currently getting, if I clear the codes and start the car I don't get a check engine light while I'm driving... As soon as I turn the motor off and go to turn it back on the CEL Comes back on until it's cleared, I'm hoping someone on here has had the same problem, thanks in advance all
 

Purple Sho

Member
Joined
Jul 12, 2021
Messages
64
Reaction score
36
Location
Estancia (outside Albuquerque) New Mexico
Start by checking fuse 67 and/or 70 in the battery junction box
You sirs are a genius it was fuse 67, its crazy ive never seen a fuse do this but it burnt the middle section out but there was just a tiny piece holding on for dear life which is why i think once the car was running it was ok.... i popped a 20 fuse in and all my lights are gone thank you again STRIPSHO
 

luigisho

SHO Member
Joined
Nov 2, 2001
Messages
11,292
Reaction score
3,730
Location
va beach,va
You sirs are a genius it was fuse 67, its crazy ive never seen a fuse do this but it burnt the middle section out but there was just a tiny piece holding on for dear life which is why i think once the car was running it was ok.... i popped a 20 fuse in and all my lights are gone thank you again STRIPSHO
My truck burned out a fuel pump (mini) fuse under the hood. Melted and I had to use a jumper wire to use an empty slot and a larger same amp fuse to make it right. Don't be afraid to do this if the slot is burned and compromised. You can always use an empty one with a jumper, or original wire to another slot if it will reach.
 

stripSHO

Tyler Durden
Joined
Sep 9, 2019
Messages
676
Reaction score
699
Location
Detroit
You sirs are a genius it was fuse 67, its crazy ive never seen a fuse do this but it burnt the middle section out but there was just a tiny piece holding on for dear life which is why i think once the car was running it was ok.... i popped a 20 fuse in and all my lights are gone thank you again STRIPSHO
You're welcome! You might want to give the wiring a good once-over to see if anything is frayed or melted or chewed up
 

Forum statistics

Threads
103,173
Messages
1,137,763
Members
13,224
Latest member
Nitric

Members online

Top