Alternator?

Discussion in 'Generation 4 - Maintenance & Troubleshooting' started by Zpak, Feb 27, 2021.

  1. Zpak

    Zpak Es Aich Oh!

    Joined:
    Jun 1, 2017
    Messages:
    1,092
    Likes Received:
    1,320
    Gender:
    Male
    Occupation:
    Work
    Location:
    NWI the 219
    So I was waiting to pick up my daughter from school, car off accessory on for radio. When I started it back up I got the Check Charging System message and battery light. Started driving and it went off. Started it this morning to go to work and had the same message and light again. Pulled out of my driveway and had no power steering. Wrestled it back in the garage and checked the battery volts while still running and only got 11.6. No time before work to do any more testing but I’m assuming the alternator is smoked.

    Anything else I can do to confirm? And, anybody ever change one? Doesn’t look super fun.
     
  2. GHNorth

    GHNorth SHO Member

    Joined:
    Mar 31, 2016
    Messages:
    117
    Likes Received:
    117
    Gender:
    Male
    These cars eat batteries. I would check that first.
     
    Hebes10 likes this.
  3. Nova

    Nova SHO Member

    Joined:
    Jul 27, 2018
    Messages:
    470
    Likes Received:
    726
    Location:
    US
    Maybe it's just a bad battery

    Sent from my SM-G986U using Tapatalk
     
  4. yaycandy

    yaycandy SHO Member

    Joined:
    Jul 2, 2018
    Messages:
    1,587
    Likes Received:
    990
    Location:
    Sweden
    I had same issues and it was the battery. Even though it was 3-4 years old. I put a new tough max in it and it made alot of issues go away like tuning wise. Old battery is in my old yard truck doing fine
     
  5. Zpak

    Zpak Es Aich Oh!

    Joined:
    Jun 1, 2017
    Messages:
    1,092
    Likes Received:
    1,320
    Gender:
    Male
    Occupation:
    Work
    Location:
    NWI the 219
    Battery is my third, new in august 2020. Knowing these cars destroy them wouldn’t surprise me but six months.
     
    Hebes10 likes this.
  6. yaycandy

    yaycandy SHO Member

    Joined:
    Jul 2, 2018
    Messages:
    1,587
    Likes Received:
    990
    Location:
    Sweden
    Check grounds. There are a few. One of mine was iffy and i cleaned it up also. Check alternator wiring also
     
  7. Zpak

    Zpak Es Aich Oh!

    Joined:
    Jun 1, 2017
    Messages:
    1,092
    Likes Received:
    1,320
    Gender:
    Male
    Occupation:
    Work
    Location:
    NWI the 219
    Thanks for the reply’s. I’ll poke around tonight.
     
  8. Majestic

    Majestic SHO Member

    Joined:
    Aug 28, 2016
    Messages:
    528
    Likes Received:
    397
    Gender:
    Male
    Probably Ford's stupid BLM. Did you reset it when replacing the batteries?
     
  9. Zpak

    Zpak Es Aich Oh!

    Joined:
    Jun 1, 2017
    Messages:
    1,092
    Likes Received:
    1,320
    Gender:
    Male
    Occupation:
    Work
    Location:
    NWI the 219
    I did not. I know it exists but that’s as far as it goes. How do you reset it?
     
  10. Majestic

    Majestic SHO Member

    Joined:
    Aug 28, 2016
    Messages:
    528
    Likes Received:
    397
    Gender:
    Male
    You can reset it with Forscan. I don't know how much good it does, though. I still have issues with it.
     
  11. Zpak

    Zpak Es Aich Oh!

    Joined:
    Jun 1, 2017
    Messages:
    1,092
    Likes Received:
    1,320
    Gender:
    Male
    Occupation:
    Work
    Location:
    NWI the 219
    That’s what I figured. I don’t have forscan. I looked at videos with a sequence of flashing the brights five times and hitting the brake three times. Had my wife try it since I’m not home and she said it didn’t work.
     
  12. Majestic

    Majestic SHO Member

    Joined:
    Aug 28, 2016
    Messages:
    528
    Likes Received:
    397
    Gender:
    Male
    I haven't done this, and I'm not saying that you should, but I have seen instructions on how to disconnect the BMS monitor from the negative battery cable. My car always starts and runs fine, but it will not maintain a full charge no matter what. I can disconnect the battery and charge it to full, then reconnect it and reset the BMS in Forscan, and within a couple of days it will be back to 12 volts or less. The charging system tests fine, so I think the BMS is fubared.
     
  13. Hebes10

    Hebes10 SHO Member

    Joined:
    Jan 9, 2014
    Messages:
    101
    Likes Received:
    53
    Gender:
    Male
    Occupation:
    Mining Health & Safety Research
    Location:
    Pittsburgh, PA
    I've gone through two batteries where the voltage tests fine but the amps are very low. Had to bring it in to dealer to confirm bad battery.
     
  14. Zpak

    Zpak Es Aich Oh!

    Joined:
    Jun 1, 2017
    Messages:
    1,092
    Likes Received:
    1,320
    Gender:
    Male
    Occupation:
    Work
    Location:
    NWI the 219
    Pulled the codes:
    P0625 - generator field/F terminal circuit low
    P065B - generator control circuit range/performance

    Cleaned anything ground, terminal, and plug related around the battery. I’m getting 12.1 volts on the battery sitting, and 11.3 while running. Tested my Edge battery for reference, 12.5 sitting and 14.4 running.

    Unfortunately, I don’t think it’s the battery.
     
  15. yaycandy

    yaycandy SHO Member

    Joined:
    Jul 2, 2018
    Messages:
    1,587
    Likes Received:
    990
    Location:
    Sweden
    Time to replace alternator. How many miles on it? You can remove it and get it tested at like an autozone.
    Buy either oem or denso
     
  16. Zpak

    Zpak Es Aich Oh!

    Joined:
    Jun 1, 2017
    Messages:
    1,092
    Likes Received:
    1,320
    Gender:
    Male
    Occupation:
    Work
    Location:
    NWI the 219
    I started it several times and it started fine. Runs for about thirty seconds then the check charging system warning comes up and battery light. As soon as it pops up the steering is gone.
     
  17. Zpak

    Zpak Es Aich Oh!

    Joined:
    Jun 1, 2017
    Messages:
    1,092
    Likes Received:
    1,320
    Gender:
    Male
    Occupation:
    Work
    Location:
    NWI the 219
    Just a tick under 90K miles
     
  18. yaycandy

    yaycandy SHO Member

    Joined:
    Jul 2, 2018
    Messages:
    1,587
    Likes Received:
    990
    Location:
    Sweden
    Or have ford check it. They will charge alot for the work but not the diagnostics
     
  19. PaulTAutoX

    PaulTAutoX SHO Member

    Joined:
    Jan 20, 2005
    Messages:
    124
    Likes Received:
    87
    Location:
    San Ramon, CA
    Are those models electric steering? If so, ignore me. If not, sounds like a connection between the alternator showing low and PS not working, I can only figure belt-related.
     
    Zpak likes this.
  20. Majestic

    Majestic SHO Member

    Joined:
    Aug 28, 2016
    Messages:
    528
    Likes Received:
    397
    Gender:
    Male
    Electric. I've started getting the random p0016 code that will go away when I charge the battery overnight. I ordered a new battery as I also get the check charging system message. Fortunately, the car runs fine and I don't lose steering.
     
    Zpak likes this.

Share This Page

If you wish to help keep SHOforum running, please click the donation button below