Alternator Output Control Relay 89 and 90 the same?

Discussion in 'Gen 1 & 2 - Engine, Exhaust, Drive Line & AC syste' started by shorage, Aug 23, 2019.

  1. shorage

    shorage SHO Member

    Joined:
    May 17, 2001
    Messages:
    220
    Likes Received:
    36
    Gender:
    Male
    Occupation:
    IT Security
    Location:
    Marshall, VA
    Good evening y'all.

    So i was curious if the Alternator Output Control Relay is the same for both the 89 and 90?
    I attached snapshot of the 89 and 90 EVTM regarding this item but it is not clear if it the same part number.

    I am rewiring my 89 with a 90 harness and i think i forgot to pull this item. Thoughts?

    Thanks

    Frank Costa
    89 with a 90 nervous system
     

    Attached Files:

  2. BaySHO Performance

    BaySHO Performance SHO Member

    Joined:
    Feb 25, 2001
    Messages:
    236
    Likes Received:
    200
    Location:
    SF South Bay
    Home Page:
    Pic 1 is for a 2.5l engine, not a SHO. The component diagram is for a SHO which shows an alternator output control relay, but it actually doesn't exist.
     

    Attached Files:

    sperold likes this.
  3. NoSlo

    NoSlo GoldMember

    Joined:
    Aug 21, 2003
    Messages:
    663
    Likes Received:
    445
    Location:
    Portland, OR
    Home Page:
    Are you having problems with your heated windshield, that you suspect the control relay?

    Oh, wait - SHOs didn't come with heated windshields...

    [​IMG]
     
  4. shorage

    shorage SHO Member

    Joined:
    May 17, 2001
    Messages:
    220
    Likes Received:
    36
    Gender:
    Male
    Occupation:
    IT Security
    Location:
    Marshall, VA
    Well, that explains it. LOL. Thanks
     
  5. shorage

    shorage SHO Member

    Joined:
    May 17, 2001
    Messages:
    220
    Likes Received:
    36
    Gender:
    Male
    Occupation:
    IT Security
    Location:
    Marshall, VA
    No, im swapping a 90 harness into my frankenstien 89 SHO. The dash is a 90 and a long time ago in a state far far away i created an adapter using donor harneses to adapt the 90 dash harness to a 89 engine bay harness. i couldn't get the gauges to work. I figured its faster to just swap the harness. But i could be wrong. LOL
     
  6. luigisho

    luigisho SHO Member

    Joined:
    Nov 2, 2001
    Messages:
    8,641
    Likes Received:
    1,678
    Location:
    va beach,va
    Home Page:
    Well keep us updated on that. Sounds like not fun! but maybe useful considering wiring issues at this age
     
  7. shorage

    shorage SHO Member

    Joined:
    May 17, 2001
    Messages:
    220
    Likes Received:
    36
    Gender:
    Male
    Occupation:
    IT Security
    Location:
    Marshall, VA
    So far so good, created new post with updates.
    https://shoforum.com/index.php?threads/90-engine-harness-to-89-engine-connectors.139898/

    Please reply on there if you can, Not sure if i linked it correctly.

    The following is from that post
    ----------------------

    Need 2 connectors to make an adapter. I am wiring a 90 "engine harness" to the 89 engine connectors. I need to create an adapter. Which is preferred to splicing into my "new" harness. Anybody have these? I would call them female connectors. I found the black one but i am not paying 80 bucks for it.

    Apparently, they swapped from Male to Female on the "On Engine Harness" from 1989 to 1990

    Just for clarification. I see 4 harnesses.

    1) Dash Harness (out of firwall)
    2) Light Harness/ABS/Airbag Harness
    3) Engine Harness (Around engine and connects CCRM
    4) On Engine Harness (sticks out the bottom of the throttle body into the valley)

    I am sure i am naming them wrong, if anyone know the names, i will refer them to the proper names.


    https://connectorexperts.com/i-24488497-ce8015f.html…
     

    Attached Files:

  8. shorage

    shorage SHO Member

    Joined:
    May 17, 2001
    Messages:
    220
    Likes Received:
    36
    Gender:
    Male
    Occupation:
    IT Security
    Location:
    Marshall, VA
    Well, its running, at first i thought my adapter was poo poo but i swapped the 91 MTX - L0S pcm in place of the 89 B9B i had in it and it fired right up.
     
    Last edited by a moderator: Aug 27, 2019
    luigisho likes this.

Share This Page

If you wish to help keep SHOforum running, please click the donation button below