2011sho nonpp alternator change

Discussion in 'Generation 4 - Maintenance & Troubleshooting' started by Laramie Brown, Aug 12, 2020.

  1. Laramie Brown

    Laramie Brown Member

    Joined:
    Oct 14, 2018
    Messages:
    32
    Likes Received:
    4
    Gender:
    Male
    Occupation:
    Heating and air conditioning
    Location:
    Denver co
    I have a 2011 sho non pp basically stock k&n drop in filter and a stx x4 tuner using stock tune cause I cant afford to get custom tunes so I went to start it Monday morning and only get click click so I use the jump box to start it and let it run a little to hopefully charge the battery 20 minutes or so I shut it off and it restarts just fine drive for about 20 to 30 minutes go in a store come back out wont start. Figure alternator So Igo by autozone and they confirm soi changed my alternator pain in the ass in my opinion get it all back together and I have 1 wire that's not connected I've looked everywhere I can with out taking anything back apart the dash shows a oil canister so I figure oil pressure sending unit butI still cant seem to locate it or I could be wrong all together might anyone know where the oil pressure sending unit is. It's the only 1 wire molex in the same loom as the throttle and the other problem is that car is still wat slow to start and using a volt meter on the battery earlier it read 10.6 battery is only a year old anyone have any ideas thanks in advance

    Sent from my SM-G960U using Tapatalk
     
  2. luigisho

    luigisho SHO Member

    Joined:
    Nov 2, 2001
    Messages:
    10,389
    Likes Received:
    3,285
    Location:
    va beach,va
    Home Page:
    These things eat batteries. Failing alts will also eat batteries.
     
  3. Laramie Brown

    Laramie Brown Member

    Joined:
    Oct 14, 2018
    Messages:
    32
    Likes Received:
    4
    Gender:
    Male
    Occupation:
    Heating and air conditioning
    Location:
    Denver co
    So I found where the wire goes I guess I'll try a new battery

    Sent from my SM-G960U using Tapatalk
     

Share This Page

If you wish to help keep SHOforum running, please click the donation button below