1994 Taurus SHO White 44k miles

Discussion in 'SHO Trader' started by Tim Devine, Sep 25, 2019.

  1. tompumped

    tompumped SHO Member

    Joined:
    Jan 14, 2006
    Messages:
    724
    Likes Received:
    136
    Location:
    VT
    The chances of getting so many bad used sensors is impossible. Its either intermittent wiring issues or more than likely coolant leaking on it. The coolant leak could be a small drip that evaporates and isnt visible.
    Ive never had a problem with the pump o rings failing only weeping out of the hole. Then again I change my pumps and crank sensors at 70 to 100k. Ive also never had issues with crank sensors failing and even sold a used one recently that works fine. Ive had a sho on the road since 02 and they were my daily during most of that time until recently.
     
  2. Tim Devine

    Tim Devine New Member

    Joined:
    Sep 23, 2019
    Messages:
    18
    Likes Received:
    13
    Gender:
    Male
    Location:
    St. Augustine
    Yes, the original one in the car that I bought new failed from coolant leaking into it, this is the first used one I purchased that has this issue. Same exact symptoms as when my original sensor was cooked from coolant.
     
  3. walsh82

    walsh82 Member

    Joined:
    Apr 25, 2010
    Messages:
    38
    Likes Received:
    4
    Occupation:
    Ford Technician
    Location:
    illinois
    Wish this was closer to Illinois
     
  4. Old Stang

    Old Stang New Member

    Joined:
    Jul 17, 2008
    Messages:
    10
    Likes Received:
    1
    Gender:
    Male
    Location:
    Woodstock, GA
    sent you a PM :)
     
  5. Will

    Will Member

    Joined:
    Apr 7, 2003
    Messages:
    33
    Likes Received:
    0
    Gender:
    Male
    Location:
    central ohio
    Not sure if this is still around, but sent you a message. I'm off all week and have an empty trailer :)
     
  6. Tim Devine

    Tim Devine New Member

    Joined:
    Sep 23, 2019
    Messages:
    18
    Likes Received:
    13
    Gender:
    Male
    Location:
    St. Augustine
    I just wanted to update the post to let everyone know that my SHO has been SOLD and is going to a new home. Thanks SHO Forum!
     
    zoomlater likes this.
  7. Will

    Will Member

    Joined:
    Apr 7, 2003
    Messages:
    33
    Likes Received:
    0
    Gender:
    Male
    Location:
    central ohio
    Glad to see it sold, sad I didn't get to get there first!
     
  8. Old Stang

    Old Stang New Member

    Joined:
    Jul 17, 2008
    Messages:
    10
    Likes Received:
    1
    Gender:
    Male
    Location:
    Woodstock, GA
    Well, the SHO arrived in my driveway safe and sound on Friday (9/04), now the fun begins!
    I can't say enough good things about the seller; Tim was very honest and transparent about the car and extremely patient and helpful with the coordination of the shipping from FL to GA. Thanks again Tim!

    I'd also like to thank the SHO Forum as I would not have found this SHO had it not been for them ... especially keeping my login info since 2008... LOL!
     
    zoomlater likes this.

Share This Page

If you wish to help keep SHOforum running, please click the donation button below