11-12psi dumping boost on wot after boost launch

Discussion in 'Generation 4 - Maintenance & Troubleshooting' started by Davidsiebert2, Mar 26, 2018.

  1. Davidsiebert2

    Davidsiebert2 SHO Member

    Joined:
    Feb 28, 2018
    Messages:
    8
    Likes Received:
    1
    Gender:
    Male
    I’m only holding 11-12psi during wot and when I boost launch the car at the top of first it’s falling on its face then picks back up around the end of 2nd. Any ideas.
     
  2. SHOdded

    SHOdded SHO Member

    Joined:
    Dec 25, 2011
    Messages:
    6,341
    Likes Received:
    2,452
    Location:
    Maryland
    check the hoses atop the intake manifold. might be one or two loose. ford did not clamp them down, you might want to rectify that.
     
    krewat likes this.
  3. moonie

    moonie SHO Member

    Joined:
    Jun 28, 2012
    Messages:
    105
    Likes Received:
    84
    Location:
    NC
    Is this with traction control on or off? If it is on you might try with it off, when the traction control engages it can feel like the car falls on its face.
     
    krewat likes this.
  4. Davidsiebert2

    Davidsiebert2 SHO Member

    Joined:
    Feb 28, 2018
    Messages:
    8
    Likes Received:
    1
    Gender:
    Male
    It is with traction control off.
     
  5. bpd1151

    bpd1151 Lurking Around

    Joined:
    Feb 21, 2010
    Messages:
    1,365
    Likes Received:
    2,382
    Gender:
    Male
    Occupation:
    LEO 23+yrs
    Location:
    SHOcago 'Burbs
    I would also remove and check the factory, OEM, electric BOV's and check the orange colored diagphragms by gently pulling outward on the plunger itself, in order to perform a visual inspection.

    Very similar to the symptoms I experienced when at Great Lakes Dragway back in 2015 during the National SHO Convention track day.
     
    SHOdded likes this.
  6. Davidsiebert2

    Davidsiebert2 SHO Member

    Joined:
    Feb 28, 2018
    Messages:
    8
    Likes Received:
    1
    Gender:
    Male
    Ok I will do that thank you.
    Not sure why my signature doesn’t pop up but the car is
    Hard pipes , 3 bar , 160 stat, catless downpipes , airflow dynamics cai, upr catchcan, mid muffler delete , soon billet compressor wheels :)
     
  7. mval

    mval SHO Member

    Joined:
    Nov 17, 2010
    Messages:
    123
    Likes Received:
    72
    Location:
    MISSOURI
    that was a sad day for the gen4/5's. we were all looking to see you put the blue turd in it's place, your rear view mirror!!!
     
    SHOdded likes this.
  8. bpd1151

    bpd1151 Lurking Around

    Joined:
    Feb 21, 2010
    Messages:
    1,365
    Likes Received:
    2,382
    Gender:
    Male
    Occupation:
    LEO 23+yrs
    Location:
    SHOcago 'Burbs
    Yea.... I was quite visibly not a happy camper that day.

    Luckily it was an easy fix. But at the time I had no clue, and I'm not even sure if any others had experienced that same failure of that same exact part.

    And if they did, it was never posted about.

    Which is silly if that was the case. We're all here to help each other out.

    Oh well. That blue turd is putting down some serious #'s now. Record setting in fact for a Non-Ecoboost SHO.

    But then again, It's a true, dedicated track car, stripped bare, caged, and umm yea.....

    Not likely to catch Zach now. But hey, if someone were to perform similar mods and make a GEN 4 or GEN 5 SHO a true, dedicated track car, they'll certainly have him looking over his shoulder, and then ahead at their tail lights. LOL.

    Zach deserves all the accolades being bestowed upon him. He's served the SHO platform incredibly well.
     
    Last edited: Apr 2, 2018
    SHOdded likes this.
  9. Davidsiebert2

    Davidsiebert2 SHO Member

    Joined:
    Feb 28, 2018
    Messages:
    8
    Likes Received:
    1
    Gender:
    Male
    Also wanna add that it only happens with my unleashed tune and ssi tune but does not happen with my Livernois 93 stage 4+x tune. For what it’s worth.
     
  10. Lorenzo Dimas

    Lorenzo Dimas El_SHO

    Joined:
    Feb 13, 2017
    Messages:
    42
    Likes Received:
    14
    Gender:
    Male
    Did u get a CEL?
     
  11. Davidsiebert2

    Davidsiebert2 SHO Member

    Joined:
    Feb 28, 2018
    Messages:
    8
    Likes Received:
    1
    Gender:
    Male
    No I did not
     
  12. Lorenzo Dimas

    Lorenzo Dimas El_SHO

    Joined:
    Feb 13, 2017
    Messages:
    42
    Likes Received:
    14
    Gender:
    Male
    Im having an issue also at wot it studders and if i keep on it falls on its face completly untill i let off even with stock tune
     
  13. bpd1151

    bpd1151 Lurking Around

    Joined:
    Feb 21, 2010
    Messages:
    1,365
    Likes Received:
    2,382
    Gender:
    Male
    Occupation:
    LEO 23+yrs
    Location:
    SHOcago 'Burbs
    No CEL for me either, when my diaphragm failed on the OEM BOV.

    Tell'n you, take them both off, and gently pull the plunger outward until you see the orange material exposed.

    Do a 360 visual inspection of that orange material and ensure it is not compromised in any way.

    Here's a pic of mine when crapped out.... You can see an actual piece of the diaphragm missing in the center.
    [​IMG]
     
    Last edited: Apr 17, 2018
  14. Lorenzo Dimas

    Lorenzo Dimas El_SHO

    Joined:
    Feb 13, 2017
    Messages:
    42
    Likes Received:
    14
    Gender:
    Male
    Ok will do after work today! And when that happened u bought a new bov or they sell rubbers?
     
  15. bpd1151

    bpd1151 Lurking Around

    Joined:
    Feb 21, 2010
    Messages:
    1,365
    Likes Received:
    2,382
    Gender:
    Male
    Occupation:
    LEO 23+yrs
    Location:
    SHOcago 'Burbs
    Bought a new replacement. Wasn't that much money. All was well after that.
     
    Lorenzo Dimas likes this.
  16. Juicybaka

    Juicybaka SHO Member

    Joined:
    Jan 24, 2018
    Messages:
    75
    Likes Received:
    19
    Gender:
    Male
    Thank you would have been nice....
     
  17. bpd1151

    bpd1151 Lurking Around

    Joined:
    Feb 21, 2010
    Messages:
    1,365
    Likes Received:
    2,382
    Gender:
    Male
    Occupation:
    LEO 23+yrs
    Location:
    SHOcago 'Burbs
    Huh....???

    Why would I be thanking myself for providing a potential solution based upon my own experience...?

    Confused. Maybe my coffee hasn't kicked in quite yet.
     
  18. SHOdded

    SHOdded SHO Member

    Joined:
    Dec 25, 2011
    Messages:
    6,341
    Likes Received:
    2,452
    Location:
    Maryland
    Failed sometime ago, right? In the process of building/testing the built engine at Livernois?
     
  19. bpd1151

    bpd1151 Lurking Around

    Joined:
    Feb 21, 2010
    Messages:
    1,365
    Likes Received:
    2,382
    Gender:
    Male
    Occupation:
    LEO 23+yrs
    Location:
    SHOcago 'Burbs
    Wasn't really testing the motor per se..... I had enough miles accrued at the time the 2015 Nat'l SHO Convention rolled into town, that I felt comfortable taking it up to GLD for what was anticipated to be it's 1st record run.

    But nope, wasn't meant to be.

    Not sure when that diaphragm failed TBH.

    But suffice to say all the symptoms being described by others posting here, were exactly what was occurring in this scenario of mine. Thus why I offered the suggestions I have.
     
    SHOdded and Lorenzo Dimas like this.
  20. Lorenzo Dimas

    Lorenzo Dimas El_SHO

    Joined:
    Feb 13, 2017
    Messages:
    42
    Likes Received:
    14
    Gender:
    Male
    Thanxs but no luck they both seem to be intact :/
     
    bpd1151 likes this.

Share This Page

If you wish to help keep SHOforum running, please click the donation button below