Recent Activity

Activity stream for all registered members at SHO Forum.

  1. SHOMON liked luigisho's post in the thread Newbie having timing issues.

    ^^ x2. The entire timing belt installation from the service manual is there.

    Sep 22, 2018 at 4:47 PM
  2. luigisho replied to the thread Newbie having timing issues.

    ^^ x2. The entire timing belt installation from the service manual is there.

    Sep 22, 2018 at 4:41 PM
  3. SHOMON replied to the thread Newbie having timing issues.

    The rear timing cover has all of the index marks on it. Line the cams up to the ones on the top and the lower timing belt pulley to the...

    Sep 22, 2018 at 4:32 PM
  4. luigisho replied to the thread Valve cover bolt problem.

    read up on it and then coil the hole and you should be in business. Alot of us have had to do this.

    Sep 22, 2018 at 4:26 PM
  5. SHOMON liked luigisho's post in the thread Question on Rod Bearings.

    Just know that you can do the job with the engine in the car by dropping the y-pipe and oil pan. So you will need oil pan seals (they...

    Sep 22, 2018 at 4:25 PM
  6. MHW100 replied to the thread Test drive and disappointed.

    I tried searching for a result of 91 vs 93 and couldn't find anything definitive .

    Sep 22, 2018 at 3:57 PM
  7. Scott Beckett replied to the thread Crank no Start.

    I think it's going to be a safe bet that it's this tone ring. Makes me feel better that there's a clear difference. Hopefully it'll be...

    Sep 22, 2018 at 3:57 PM
  8. Jeff2017 replied to the thread 2012 SHO Mod Recommendations.

    I run stock, but if I were to tune here is the list: 1) LMS 93 octane tube, 3 bar map, 160F thermostat, plugs 2) Down pipes + CAI 3)...

    Sep 22, 2018 at 3:17 PM
  9. Crizcocane replied to the thread Valve cover bolt problem.

    Its threaded whole I can get the bolt out no problem just doesn't tighten down.

    Sep 22, 2018 at 2:32 PM
  10. Jeff2017 replied to the thread Test drive and disappointed.

    Io I only run top tier gas 93 octane in mine. The next available is 89 then 87 so I haven't run 91 before. My guess is in hot weather...

    Sep 22, 2018 at 2:09 PM
  11. Craig93GreenMTX replied to the thread Newbie having timing issues.

    Ok, does anyone have any keywords for finding how to set the timing from my situation. I've been searching, and cant find anything on...

    Sep 22, 2018 at 1:52 PM
  12. luigisho replied to the thread Valve cover bolt problem.

    So is the threaded hole stripped out or did a piece of the threaded bolt break off inside and nothing can grab and seat? Either might...

    Sep 22, 2018 at 1:45 PM
  13. luigisho replied to the thread Test drive and disappointed.

    That's a huge difference. Similar time of year? ie major ambient temp differences?

    Sep 22, 2018 at 1:32 PM
  14. luigisho replied to the thread Question on Rod Bearings.

    Just know that you can do the job with the engine in the car by dropping the y-pipe and oil pan. So you will need oil pan seals (they...

    Sep 22, 2018 at 1:20 PM
  15. Crizcocane posted a new thread.

    Valve cover bolt problem

    Alright guys so I did the intake and valve cover gaskets, one of the upper VC bolts on the rear was tough coming off had to help it with...

    Forum: Gen 1 & 2 - Engine, Exhaust, Drive Line & AC syste

    Sep 22, 2018 at 1:19 PM
Loading...

If you wish to help keep SHOforum running, please click the donation button below