SHOdded
Last Activity:
Dec 8, 2019 at 7:01 AM
Joined:
Dec 25, 2011
Messages:
8,274
Likes Received:
3,669
Trophy Points:
113
Media:
4
Albums:
2
Location:
Maryland

Share This Page

SHOdded

SHO Member, from Maryland

Supporting Member
SHOdded was last seen:
Dec 8, 2019 at 7:01 AM
    1. Crazyeights
      Crazyeights
      Do you know a way to find out the production numbers for 2015 units and what build number the vehicle is based on color etc? I got it on my 2011 from Ford Performance, but it isn't available through them now.
      Thanks
      1. SHOdded
        SHOdded
        I believe 2013 was the last Model Year that numbers were officially available for. You could ask FPS directly, but they may just toe the line.
        Nov 29, 2019
      2. Crazyeights
        Crazyeights
        I called them and the gentlemen I spoke to tried to look it up and commented that his system showed that that information wasn’t available yet. I’ve only seen one other SHO the same color as mine and based on the wheels it wasn’t a PP. Either way, I say that there weren’t a lot of SHO in Impact Blue Metallic.
        Nov 29, 2019
    2. Auggie
      Auggie
      I have for some reason have not been able to post or reply lately. I am a new member and when I first signed up I was able to do both. Can you help me with this problem. [email protected] Thanks Auggie
    3. Texaco51
      Texaco51
      I have a 1991 Taurus SHO Gen 1 I need the access codes etc to access the chip to tune the engine. Anyone have any ideas?
    4. Texaco51
      Texaco51
      I have a 1991 Taurus SHO Gen 1 I need the access codes etc to access the chip to tune the engine. Anyone have any ideas?
    5. ctubutis
      ctubutis
      Thanks for the reps! :)
    6. SHOdded
      SHOdded
      Good work deserves to be applauded :)
    7. ctubutis
      ctubutis
      Thanks for the reps. :)
    8. H.G.David
      H.G.David
      hello,

      i have a 1994 atx- had remanufacterd trans. had problems.
      now ck engine light came on about 20 minutes, when off, all of a sudden
      it felt like i had no trans. no reverse no forward gears nothing.
      had codes ck-vechicle speed sensor,no tach signal,and no third gear.

      `had it rebuilt 2-1-2008, never shifted thru all gears w/ 0/d off-just 1st and 2nd.
      o/d on it would shift 1,2,3,4 no problem.
      mehcanic says transmission is shot.its got only 16,000 miles on it.
      got trans 2/2008 from gear transmissions aka american transmission technolgy
      aka phonix remaunufacter transmissions.

      thanks for your help, was trying to post, some how i got here
  • Loading...
  • Loading...
  • About

    Location:
    Maryland

    Signature

    '95 ATX: Status Unknown
    '92 MTX: R.I.P.
  • Loading...
  • Loading...

If you wish to help keep SHOforum running, please click the donation button below